SeaKnots

My fresh water system works great for about one minute through all facets (opened one at a time) and then declines to a slow drip.

I'm working one tank at a time, checked the vents (water comes out of them when the water tanks are filled to the top), in line filter screen is clean, facet screens are clean.

Just replaced the water pump, it recharges after being on for a minute and does not cycle on until the water is being used.

Any suggestions old be greatly appreciated

Thanks

Chris

S/V TENACITY II

B40#197

Views: 22

Latest Activity

Slawomir is now a member of SeaKnots
Nov 2
Maris Ahmed updated their profile
Oct 28
Profile IconJoel Carvalho, Nina, Robert Hindman and 1 more joined SeaKnots
Oct 28
Robert & Sandy replied to sam's discussion need VIN alternate location urgently in the group Beneteau 40 & 43
"Sam On my 43 the VIN is on one of the hull floors (transverse ribs under the floor boards) adjacent to the stove. The are moulded into the gelcoat. Hope this helps. Regards Bilgolabands"
Oct 17
Alice Wong updated their profile
Sep 29
Eleonore Cowan updated their profile
Sep 29
Mike Brown replied to Wayne's discussion Farewell all in the group Beneteau 40 & 43
"Hang in there!"
Sep 27
Wayne replied to Wayne's discussion Farewell all in the group Beneteau 40 & 43
"Mike thank you so much for the inspiration as it is greatly appreciated and much needed.  "
Sep 27
ADVERTISE ON SEAKNOTS CONTACT US AT: 
candrac@sailforwater.com

© 2020   Created by CAN DRAC.   Powered by

Badges  |  Report an Issue  |  Terms of Service