SeaKnots

Has anyone had their engine hour meter stop working? Ours is displaying strange letters and not indicating the hours. With no fuel gauge (long ago gave up on trying to use it / believe it/ fix it) I depend on engine hours for fuel consumption. I now keep a running hour log also.

Anyone had the hour meter quit or been able to fix it?

Thanks for any and all help or suggestions.

Sam

LONGHAWK

B43,hull #9

Views: 1219

Replies to This Discussion

I experienced this problem on a prior Beneteau with a Yanmar hour meter and recently found this "fix," but since the boat was sold, have no experience as to whether it works. You'll need to investigate and make your own decision.

a href="http://forums.beneteau.sailboatowners.com/showthread.php?p=997248&highlight=yanmar%20tach-hour%20meter%3E" target="_blank">http://forums.beneteau.sailboatowners.com/showthread.php?p=997248&a...;

Apparently the site won't format the URL. I found this "fix" on the Beneteauowners.com website, searching for Yanmar Tach-hour. Attached is the document from that site. As per my earlier post, no personal knowledge as to whether this works.

Attachments:

I am having this issue with by B43 hull#40. Interested in finding out how you resolved it Sam. I used the approach provided by Paul on my last Beneteau which had the same hour meter issue. Did this right before I sold the boat and worked fine for the few weeks before the boat was delivered to the new owner. I tried it with my B43, but could not get the hour meter to come back to life.

I will most likely replace the entire tach/hour meter with a generic VDO model (VDO Part #: 333-163), but not sure how I can determine how many hours are actually on the boat (I only glanced at the hour meter during the sea trial and noticed it was at 2 hundred odd hours, but did not look that closely as it was near what the seller advertised - it has not worked since so I can only approximate the hours). Before I install the new hour meter, I would like to run up the hours on the meter to accurately reflect the engine hours.

Any thoughts?

Sorry for the delayed response, but...

I finally added an additional hour meter. My engine hour  display on the tach was intermittent, it was keeping the cumulative hours but  just not displaying it consistently. It appeared to cycle with some electrical input fluctuation, possibly alternator kick in and out as state of battery charge varied. I purchased a simple meter and wired it to a constant 12 v and let it run until it matched the engine hours on the tach. I was able to catch the display at various times and home in on the data. I sourced a switched alternator output to feed the meter on final installation.

I added the hour meter in the aft cabin, so as an added benefit I can read and calculate fuel consumption easily from within the boat just prior to fueling (since I have to rely on the calculation method with the infamously useless fuel gauge!),

Good luck.

Thanks for the reply Sam. I will probably have to guess the hours as I have not seen it show anything since my test sail. Also, with everything I have read about the inaccuracy of the fuel gauge, I feel like I will be flying blind without an hour meter on my long cruise I am about to kickoff, so I will install a separate hour meter like you did and hope I can catch a glimpse of the hours on the tach during my cruise.

Larry try checking the engine hour gauge at night. I noticed on mine that while I couldn't see it in broad dayloght it was lit enough to view in the dark.
Mike

Hi,

Just before my starting battery (six years old) went dead when I was at anchor (that was another story) I was having erratic readings or better saying - the lcd was very difficult to read even during the night. When the new battery was mounted, the lcd came to live again. I am not sure if the battery problem is related to difficult lcd readings, but it was the only signal that I had before the battery died one afternoon when I was tried to switch ON the engine in order to operate the windlass to pull the anchor.

Luis

I had the same problem with my B43 #50.   I purchased a quartz Hewlett hour meter from Amazon for $16.00 and installed it right under the tach after removing the 4 screws that hold the instrument module and cutting a 1" x 1.5 inch hole for the new hour meter. I wired it directly to the switch and now the hour meter starts counting as soon as the ignition switch is turned on.  I don't leave the switch turned on if the motor is off so I don't worry about accumulating hours unnecessarily.    I was able to bring the hour meter to match the original by hooking it up to my starting battery for about 18 days prior to final installation.

The installation was easy and took less than 15 minutes.  The only thing that you need to be careful of is that these hour meters are not water proof, only water resistant so I replaced the clear plexi glass instrument cover with a larger one that covers the entire face of the module and also cut a 2.5 inch hole to allow access to the ignition switch.  Ordering the new plexi glass and having the hole cut out took longer than the install of the new meter

Hi to everyone, before doing anything that can ruin your tachometer, please try this first that worked for me after having tried everything read on the internet about this problem. I had the same problem with my tachometer/hour meter (yanmar) and the tachometer was working well but without any hours showing on the LCD display. I removed the silicone (as explain in another discussion group) but it did not do anything. But what I found is probably the cause of why the hour meters does not work. On the picture included, you will see a picture of a connector where the LCD display cable connects to the board. This is what was the problem. The 6 pins was not touching the ribbon cable or the strength of the pins against the cable was not strong enough to create a good electric contact. I used a toothpick that I inserted inside the tiny hole of each pin of the connector to make them to be closer to the other side and make sure that the tension is strong enough to create a good contact. Then it was working like a brand new. So, forget the step to remove the silicone glue, this is not the problem. It worked just because people touched the ribbon cable and created a better contact. Good luck. Sorry for my typing mistakes, French is my mother tongue. Let me know if you have success with this solution.

Attachments:

Hello Jo,

I read the referred to fixes in the other forums and it was strange what people said. For me it looks like a bad contact in the connector as you say. I wrote my experience above (2015) and I must say that came to the previous state that is I can only read the hours in the night and with a light pointing to the display.

When I changed the battery in 2015, I removed the whole assembly but I was not worried with the hour meter. I was worried with the fact that pressing the Start switch, an alarm sounded and I could not start the engine. In fact I was lucky because another boat pulled me to the quay one mile away where I could get a new battery. And because I moved the assembly house around trying to fix the non Start situation, may be I touched the ribbon cable and it get a better contact. In my next winter visit to the boat (sitting in a Greek shipyard for the next summer) I will do something like you say and will use a spray contact cleaner as well.

Merci pour votre post, Luis

After trying all the fixes I finally bit the bullet and replaced the entire tach unit. Other than needing to adjust the tachometer for correct engine speed it was an easy repair. 

Mike

Should have posted my fix earlier. I had the same problem with the tach on my 323 before I bought the 43. I was able to get the hour meter to work on the 323 by following the processes out on the web about cleaning the silicon & the ribbon cable. When the 43 hour meter went out, I was able to get it back for a short time with the ribbon cable trick but it went dark again within a few weeks.

I then found boatstuff.se who sells a replacement LCD screen & ribbon cable for the hour meter. I replaced the LCD in the hour meter about a year ago and it has been working perfectly every since the replacement. I did the same procedure on a friends boat who had the same VDO/Yanmar tach and his has been working perfectly since as well. The process is very simple and Rickard from boatstuff.se was very helpful in answering my questions and providing a great PDF how-to document.

The main reason I went with this approach was that I wanted to know the hours on the boat/engine. I bought the boat second hand and while I recall seeing the hours during the sea trial, the hour meter was completely out once I took delivery. I ran the boat for a couple of years without the hour meter and did not keep the best log of hours, so I basically lost track. Once I put in the LCD, the actual hours was displayed again!

RSS

Latest Activity

vgbh cfrd posted a status
4 hours ago
Jon Overvold joined Ben's group
Nov 5
Jon Overvold posted photos
Nov 5
Jim Malone commented on Ann Marie's photo
Thumbnail

AM1

":-) Great sailing photo of a great Captain"
Nov 5
Davis Golding commented on Bradley A Destache's group Cal Sailboats
"Hello, after looking seriously at a 1974 Islander 36 that required a lot of work, I am now looking at a 1984 CAL 35 MKII which is in excellent condition. Should anyone have any words of advice on what they particularly like and dislike about the CAL…"
Nov 5
Davis Golding joined Bradley A Destache's group
Thumbnail

Cal Sailboats

A place for the Cal owners to talk about anything from there day sail to their bottom paint.
Nov 5
Profile IconJohn Perez, Davis Golding and Jon Overvold joined SeaKnots
Nov 5
vgbh cfrd posted a status
""
Nov 5
ADVERTISE ON SEAKNOTS CONTACT US AT: 
candrac@sailforwater.com

© 2017   Created by CAN DRAC.   Powered by

Badges  |  Report an Issue  |  Terms of Service