SeaKnots

My fresh water system works great for about one minute through all facets (opened one at a time) and then declines to a slow drip.

I'm working one tank at a time, checked the vents (water comes out of them when the water tanks are filled to the top), in line filter screen is clean, facet screens are clean.

Just replaced the water pump, it recharges after being on for a minute and does not cycle on until the water is being used.

Any suggestions old be greatly appreciated

Thanks

Chris

S/V TENACITY II

B40#197

Views: 106

Replies to This Discussion

Chris, if I understand correctly the problem started after you installed the new pump. If that’s correct then I’d go back and check both the intake and discharge hoses for possible blockage(s). 
Mike

Have you checked that you still have air pressure in the accumulation tank? You might have lost air. Use by cycle pump to fill the air tank and try again. 

Hi Mike:

The problem continued after I installed a new pump, thinking the old pump was the problem.

Hi Tevfik:

Thanks.

I'll check the accumulation tank tomorrow.

Do you have the same pressure issue with the shower faucet?

Unfortunately, sames pressure issue with all faucets and cockpit shower

Roger that.  I have encountered what I perceived to be reduced pressure in my galley faucet and head lav faucets before where it turned out to be debris buildup at the faucet strainer.  Doesn’t sound like that’s your problem. 

Checked air pressure in the accumulation tank 40psi.

I am perplexed...

Is there a screen in the water tank?

Chris, I’d troubleshoot both sides of the system both suction and discharge. Doing so may require rigging some jumpers around specific components of the system. Start with the discharge side disconnecting the output from the pump. Use a jumper hose to direct the water into a bucket or the bilge whichever is easiest to clean up. If the water flows properly then move downstream. If it does not then work upstream. Continue to do so until you find the cause of the problem. Good luck and keep us posted on your results. 
Mike

I am thinking that the vents may be partially blocked by spiders.

How do I clean it?

Great News!

I found the problem.

Turns out that when disconnecting and inspecting the fresh water check valve I found just enough debris (black thin plastic tape like material)  to slow down the flow!

Cleaned it out and the water pressure is back to normal.

Thanks for all your helpful suggestions

Attachments:

Chris that’s good news. The debris could have been from the tank when they cut opening for the hose fittings. Glad to hear you have it fixed. 
Mike

RSS

Latest Activity

Alice Wong updated their profile
yesterday
Eleonore Cowan updated their profile
yesterday
Music is now a member of SeaKnots
Wednesday
Profile IconNick Juno, Lola, Jayson Russell and 1 more joined SeaKnots
Tuesday
Slawomir is now a member of SeaKnots
Nov 2
Maris Ahmed updated their profile
Oct 28
Profile IconJoel Carvalho, Nina, Robert Hindman and 1 more joined SeaKnots
Oct 28
Robert & Sandy replied to sam's discussion need VIN alternate location urgently in the group Beneteau 40 & 43
"Sam On my 43 the VIN is on one of the hull floors (transverse ribs under the floor boards) adjacent to the stove. The are moulded into the gelcoat. Hope this helps. Regards Bilgolabands"
Oct 17
ADVERTISE ON SEAKNOTS CONTACT US AT: 
candrac@sailforwater.com

© 2020   Created by CAN DRAC.   Powered by

Badges  |  Report an Issue  |  Terms of Service